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Preface

This manual describes how to use the Tektronix MPEG Program Stream
Analyzer application. Using the MPEG Program Stream Analyzer, you can view
the fields and values of MPEG2 program streams and MPEG1 system streams at
the pack and PES packet level, extract and save all or part of program and
system streams, and analyze streams for coherence to the MPEG standards.

The MPEG Program Stream Analyzer is part of the MTS300 suite of hardware
and software components used to create, generate, acquire, and analyze MPEG
and DVB transport and program streams and can be used by itself or as an
integral part of the MPEG test system. If you have the Elementary Stream
Analyzers installed on your system, you can send video or audio elementary
streams directly to the appropriate analyzer for analysis at the elementary stream
level.

For information about other MTS300 test system applications, refer to the user
manuals provided with test system or software option. For information about
MTS300 test system hardware installation, specifications, and first-time
operation, refer to the MTS 300 PEG Test System Hardware and Software
Installation Technical Reference, Tektronix part number 071-0667-XX.

For information about the Windows NT Workstation operating system, refer to
the Microsoft documentation that accompanied your test system.

Table i lists the MTS300 MPEG Test System application version supported by
this manual. To verify an application version number, select Help in the
application menu bar; then select About from the Help menu.

Table i: MTS300 MPEG Test System (V5.0) supported applications 

Application Supported version

MPEG Program Stream Analyzer V1.04 and above
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Contacting Tektronix

Product
Support

For questions about using Tektronix measurement products, call
toll free in North America:
1-800-833-9200
6:00 a.m. – 5:00 p.m. Pacific time

Or contact us by e-mail:
tm_app_supp@tek.com

For product support outside of North America, contact your
local Tektronix distributor or sales office.

Service
support

Tektronix offers a range of services, including Extended
Warranty Repair and Calibration services. Contact your local
Tektronix distributor or sales office for details.

For a listing of worldwide service centers, visit our web site.

Toll-free
Number

In North America:
1-800-833-9200
An operator can direct your call.

Postal 
Address

Tektronix, Inc.
Department or name (if known)
P.O. Box 500
Beaverton, OR 97077
USA

Web site www.tektronix.com
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Getting Started

The MPEG Program Stream Analyzer is used to view and analyze MPEG1 and
MPEG2 program stream structures, fields, and values. This section lists the
various views and analysis functions enabled by the MPEG Program Stream
Analyzer and describes how to find the information you need to install and use
your analyzer the first time.

Product Description
You can display graphical representations of the MPEG structures of a program
stream using interactive view windows, called interpreted views. Interpreted
views are used to display the following MPEG program stream structures:

� Pack header

� PES packets

� Program stream map (PSM)

� Program stream directory (PSD)

In addition to the interpreted views, the analyzer provides other ways of viewing
MPEG structures and values:

� Hierarchic view

� Hexadecimal and binary views

� System clock reference (SCR) views

� Presentation time stamp/Decoding time stamp (PTS/DTS) views

You can analyze syntactic, semantic, and temporal (time-based) characteristics
of a program stream using the analysis functions provided by the analyzer. The
analysis functions provided are indicated in the following list:

� Multiplex rate analysis

� Syntactic analysis

� Consistency analysis (coherence between all components of the stream)

� System clock reference (SCR) analysis

� Presentation/Decoding time stamp (PTS/DTS) analysis
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Using the MPEG Program Stream Analyzer you can also extract individual
elementary streams for analysis later. Alternatively if you have the Tektronix
MPEG Audio Stream Analyzer and/or MPEG Video Stream Analyzer installed
on your system, you can extract an elementary stream and display a graphical
representation of it using one of the elementary stream analyzers automatically.

First Time Operation
The MPEG Program Stream Analyzer is part of a suite of hardware and software
components used to create, generate, acquire, and analyze MPEG and DVB
transport and program streams. Before you can use the analyzer, you need to
ensure that you have entered the correct password for your software configura-
tion. To enable the software you have purchased, use the procedure for entering
the general password described in the MTS300 Series Software Only Installation
Instructions, Tektronix part number 075-0630-XX.
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Operating Basics

This chapter provides a functional overview of the MPEG Program Stream
Analyzer interface elements and provides basic operating procedures that will
help you become familiar with the application. This chapter is organized into the
following sections:

NOTE. For basic Windows operating techniques such as minimizing windows or
using the scroll bars, refer to your Windows documentation.

� Functional Overview shows you how to start the MPEG Program Stream
Analyzer and describes user interface elements and characteristics of the
windows used by the analyzer.

� MPEG Program Stream Analyzer Views describes the Hierarchic view and
the common characteristics of Interpreted views.

� Basic Operations describes how to open, extract, and save program or
system stream files; how to print data encoded in the active file; and how to
exit the application.

� Menu Selections provides a table that summarizes the menu selections.
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Functional Overview
Double click the MPEG Program Stream Analyzer icon in the MPEG Test
System program group window.

The MPEG Program Stream Analyzer uses two types of windows to display the
elements of a program stream: the application window and view windows. This
section describes these window types. (See your Windows documentation for
information about common Windows display elements.)

The basic application window looks similar to the following illustration.

Title bar
Menu bar

Upper toolbar

Status bar

Edit toolbar

View
window

Application
window

Title bar. The title bar displays the application name and application icon. The
window control buttons are standard window controls and allow you to
minimize, maximize, and close the application window.

Application Window
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Menu bar. The menu bar provides access to the commands you use to control the
display, analysis, and look of the MPEG Program Stream Analyzer. A list of
menu selections is provided in Menu Selections beginning on page 2–18.
Complete descriptions of each menu selection are provided in the Options Menu
Reference section beginning on page 3–19.

Upper toolbar. The Upper toolbar provides shortcut buttons to five commonly
used menu selections. These buttons, and the menu selection they represent, are
described in Table 2–1.

Table 2–1: Upper toolbar buttons 

Button
Name/Menu
selection Menu This selection...

Open File Displays the Open dialog box. See Opening Program
Stream Files beginning on page 2–11.

Save as File Displays the Save As dialog box. See Extracting and
Saving Program Streams beginning on page 2–12.

Add View Window Displays a submenu from which you specify a view to be
displayed. See Adding Views beginning on page 3–6.

Edit toolbar.  Selecting an Edit toolbar command button is identical to selecting
the Edit menu selection of the same name. These buttons, described in
Table 2–2, allow you to move through the items of the displayed element and to
view errors in the program stream file.

Table 2–2: Edit toolbar buttons 

Button Name This selection/button...

First Item Displays the first item in the active view.

Previous Item Displays the previous item in the active view.

Go to Displays a dialog box that allows you to select the item number
of the active view you want displayed.

Next Item Displays the next item in the active view.

Last Item Displays the last item in the active view.

Number of Items Counts the number of items in the element and displays the
number in the top line of the view window.

Next error Displays the next item that has an error in the program stream
file.
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NOTE. Items are instances of specific data types, or elements. The first instance
of the program_stream_map() element in the bitstream is the first item displayed
in the PSM interpreted view.

Status bar. The Status bar, located just below the Edit toolbar, provides you with
first level help on using the menus. As you highlight a menu item, the status bar
briefly describes the selection.

View windows are used to display program stream files at different levels. Most
of the important information displayed in view windows is discussed in the
discussions of the individual view windows elsewhere in this manual. However,
in addition to standard window controls, the title bar and top line of most view
windows have the following information types in common:

View type Item number PositionFile name

� File name. Indicates the file name of the view displayed.

� View type. The view type indicates the program stream element displayed.
For instance, pack_header() and PES_packet() data represent Pack header
and PES packet elements respectively

� Item number. Indicates the item number of the element displayed. If you
have previously selected the last item, or have selected the Number of Items
command button, the item number is followed by the total number of items
for the displayed element in the bitstream.

� Position. Indicates the position (in bytes) of the first bit of information
displayed in the interpreted view relative to the first bit of the program
stream. The first bit of the program stream is zero.

View Windows
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MPEG Program Stream Analyzer Views
You can use the MPEG Program Stream Analyzer to view the program stream
and program stream elements at different levels. This section briefly describes
the three basic views (hierarchic, interpreted, and binary and hexadecimal views)
and how to access them. See Interpreted Views beginning on page 3–1, and see
Additional Views beginning on page 3–6 for more detailed information about the
various view types used by the analyzer.

The Hierarchic view window displays a graphical view of the overall structure of
the program stream indicated in the title bar of the active view window. The
Hierarchic view is displayed when you first open an program stream file as a
stream file type. See Opening Program Stream Files on page 2–11 for more
information on opening different file types.

The icons displayed show the logical structure of the active program stream,
provide access to various interpreted view and analysis functions, and allow you
to save the elementary stream data to a file. These icons, and the interpreted
views they access, are shown in Table 2–3 on page 2–6.

Icons with a red “X” on top of them indicate stream elements that are referenced
in the PS map or PS directory, yet are not present in the bitstream. Icons with a
red “?” on top of them indicate stream elements that are found in the bitstream,
yet are not referenced in the program stream map (ghost elements).

Hierarchic View
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Table 2–3: Hierarchic view icons

Icon Name Double click the
icon to display

The interpreted view
displays

Right-clicking the icon
will also allow you to

PS Pack header
interpreted view
(page 3–2)

Fields associated with the
pack_header () and
system_header()
elements of program
streams.

Perform Rate or SCR
analyses, or display a
packet map of all the
packets in the program
stream.

Pack Pack header
interpreted view
(page 3–2)

Fields found in the
pack_header () and
system_header()
elements of program
streams.

Perform Rate or SCR
analyses, or display a
packet map of the packets
in the program stream.

PSM Program stream
map  interpreted
view
(page 3–4)

Fields associated with the
program_stream_map()
element of program
streams.

PSD Program stream
directory interpreted
view
(page 3–5)

Fields associated with the
directory_PES_packet()
element of program
streams.

PES PES packet
interpreted view
(page 3–3)

Fields associated with the
PES_packet() element of
program streams.

Perform PTS/DTS anal-
yses on the selected
program stream item.

VIDEO Save Video Stream
dialog box
(page 2–16)

Analyze the video stream
using the MTS Video
Stream Analyzer, provided
you have the Elementary
Stream Analyzer installed
on your system.

AUDIO Save Audio Stream
dialog box
(page 2–16)

Analyze the audio stream
using the MTS Audio
Stream Analyzer, provided
you have the Elementary
Stream Analyzer installed
on your system.

DATA Save Data Stream
dialog box
(page 2–16)

End
Code

End Code message
window
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You can display the values encoded in program stream structures using interac-
tive view windows, called interpreted views. The interpreted views enabled by
the MPEG Program Stream Analyzer and some of the fields and values
displayed in each view are indicated in the following list:

� Pack header. The Pack header interpreted view displays SCR, multiplex rate,
audio and video bounds, and target decoder fields and values.

� Program stream map. The PSM interpreted view displays PSM header,
elementary stream ID, and CRC fields and values.

� Program stream directory. The PSD interpreted view displays PSD header,
PES position offset, and access unit PTS fields and values.

� PES packets. The PES packet interpreted view displays PES packet header,
scrambling, and PTS/DTS fields and values.

Access interpreted views by double-clicking the icons displayed in the Hierar-
chic view. See Table 2–3 on page 2–6. Page references in the table indicate
where you can find more information about the specific interpreted view.

The following sections describe the interface elements and interactive character-
istics common to all interpreted views and how to navigate through the items of
program stream elements.

Interface elements. Each interpreted view window displays the following types of
information:

� File name. The file name indicates the name of the program stream file
displayed.

� View type. The view type indicates the program stream element displayed
(for instance, pack_header() and PES_packet() data represent Pack header
and PES packet elements respectively).

File name View type PositionItem number

Field
rectangle

Value
rectangle

Field length or
position indicator

Interpreted View Windows
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� Item number. Indicates the item number of the element being displayed. (See
page 2–4 for the definition of an item.) If you have previously selected the
last item, or have selected the Number of Items command button, the item
number is followed by the total number of items for the displayed element in
the bitstream.

� Position. Indicates the position (in bytes) of the first bit of information
displayed in the interpreted view relative to the first bit of the program
stream. The first bit of the program stream is zero.

� Field rectangle. Indicates the name of the field displayed. See the description
for Field rectangles in the following section, Interactive characteristics.

� Value rectangle. Indicates the value for the field named in the Field rectangle
immediately above it.  See the description for Value rectangles in the
following section, Interactive characteristics.

� Field length or position indicator. Indicates the position in the bitstream of
the field immediately above it relative to the first bit in the current item. The
first bit of the current item is zero. You determine which type of information,
if any, is displayed using the Interpretation selection from the Options menu.

Interactive characteristics. Interpreted views display selected fields and values of
MPEG1 and MPEG2 encoded program streams. The fields and values displayed
for any given item in the program stream are represented by the field and value
rectangles displayed in the interpreted view window.

� Field rectangles. Field rectangles (the large rectangles), name the fields
analyzed by the MPEG Program Stream Analyzer and display marker bit
indicators, when marker bits are part of the field. If marker bit values are
incorrect, marker bit indicators (the vertical lines) are displayed in red.
Shaded or gray rectangles represent fields that are important indicators of the
quality of the program stream.

Double-click a field rectangle to display a pop-up message window for the
field, as shown in the following illustration. The title bar of the message
window names the field; the text below describes the field as defined by
ISO/IEC 11172-1 and ISO/IEC 13818-1. You can move this window by
clicking and dragging the title bar. Dismiss the window by clicking
anywhere outside of it in the application window.
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Double-clicking on field rectangles that look three dimensional opens a
hexadecimal view of the bitstream for the item displayed (see Binary and
Hexadecimal Views on page 2–10 for a description of the hexadecimal
view window).

� Value rectangles. Value rectangles (the small rectangles) display the value for
the field named in the large rectangle directly above it. Values can be
displayed in either decimal or hexadecimal base. To toggle between decimal
and hexadecimal base, press the F2 function key. Values displayed in red
indicate values that are in error.

Double-click a value rectangle to display a pop-up message window for the
value, as shown in the following illustration.
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The message window interprets the value for that field, and reports any
errors encoded in the bitstream. If marker bits are part of the field, the
message window also reports whether the marker bit values are correct.
Dismiss the message rectangle by clicking anywhere outside of it within the
application window.

Three dimensional value rectangles to display the number of data bytes
encoded in the bitstream for that item.

Navigating through interpreted view items. Use the Edit toolbar command buttons
(located at the bottom of the application window) to navigate through the items
of the element displayed. See Table 2–2, on page 2–3 for more information
about how to use the Edit toolbar command buttons.

NOTE. Items are instances of specific data types, or elements. The first instance
of the program_stream_map() element in the bitstream is the first item displayed
in the PSM interpreted view.

The Binary and Hexadecimal views show the bit representation, in either binary
or hexadecimal format, of the interpreted view from which it was accessed.
Access Binary and Hexadecimal views from interpreted view windows by
clicking the Add View icon on the upper toolbar and selecting Binary or
Hexadecimal from the submenu.

The blue text in the binary and hexadecimal views represent the data that appears
in the first line of the item displayed in the interpreted view.

Navigate through the items represented in the binary or hexadecimal view using
the Edit toolbar or the Edit menu selections. As you move through the items in
binary and hexadecimal views, the interpreted view from which you accessed the
binary or hexadecimal view also increments. In order to display two separate
items of the same element, you need to display two interpreted view windows
and access a binary or hexadecimal view from each.

You can also display binary and hexadecimal views of many program stream
elements by double-clicking the three dimensional data packet fields in some of
the interpreted views.

Binary and Hexadecimal
Views
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Basic Operations
This section describes how to open, extract, and save MPEG program and
system stream files; how to print information displayed in interpreted and
hierarchic views; and  how to exit the application.

The MPEG Program Stream Analyzer can display the following types of files:

� MPEG2 program streams

� MPEG1 system streams

� MPEG1 and MPEG2 PES packet streams

Opening a program stream file. To open a program stream file, use the following
procedure:

1. Select the Open command button on the Upper toolbar (or select Open from
the file menu).

2. Use standard Windows techniques to select the drive and directory that
contains the file you want to open.

Opening Program Stream
Files
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3. From the List files of type: drop-down selection box, make one of the
following selections (the list describes the elements that the analyzer
displays when you select the option):

� MPEG2 Program Stream. This will display all of the elements in
program or system stream files (opening a file as an MPEG2 Program
Stream is the default option).

� MPEG1 System Stream. This will display all of the elements of system
stream files. If the file opened using this option is an MPEG2 encoded
file, the PSD and PSM elements will not be displayed.

� MPEG2 Packets. This will display all of the PES packet elements
encoded in the program or system stream. Program and system stream
level information is not displayed when you use this option.

� MPEG1 Packets. This will display all of the MPEG1 PES packet
elements encoded in the program or system stream. If the file is an
MPEG2 encoded bitstream, the MPEG2 elements will not be displayed.

4. Select the file that you want to display from the File name: selection box (or
type the name of the file in the text box), and then select OK .

The initial display depends on the option you selected in step 3. If you open
a file as a program or system stream, the Hierarchic view is the first view
displayed. If you open a file as packets, an interpreted view is the first view
displayed.

You can extract and save complete program stream files or specific parts of the
program stream using the procedures described in this section. The following list
indicates how program stream data is saved when different views are active:

� Pack header interpreted view. When this view is active, the analyzer extracts
the packs you indicate and saves files using the pack file name extension
(.pck).

� PSM interpreted view. When this view is active, the analyzer extracts the
indicated program stream map PES packets and saves files using the PSM
packets file name extension (.psm).

� PSD interpreted view. When this view is active, the analyzer extracts the
indicated program stream directory PES packets and saves files using the
PSD packets file name extension (.psd).

� PES interpreted view. When this view is active, the analyzer extracts the PES
packets you indicate and saves files using the PES stream file name
extension (.pes).

Extracting and Saving
Program Streams
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Extracting packs. To extract and save packs from a program or system stream,
use the following procedure:

1. From a Pack header interpreted view, select the Save As command button
from the Upper toolbar (or select Save as from the File menu).

2. Choose All Packs or Select Number from the dialog box.

� Select All Packs to extract the entire stream (packs, packets, and end
code).

� Select Select Number to extract the packs you indicate in the From and
To text boxes.

3. If you chose Select Number, enter the pack item numbers for the packs you
want to save in the From and To text boxes. The numbers you enter in the
text boxes are inclusive.

4. After you press OK, a standard Save As dialog box is displayed. Using
standard Windows techniques, indicate the file in which to save the extracted
data.

Pack header data saved using this procedure are saved using the pack stream
file name extension (.pck).
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Extracting packets. To extract and save packets from a program or system stream,
use the following procedure:

1. Navigate to the interpreted view for the stream element you want to save,
and then select the Save As command button from the Upper toolbar (or
select Save as from the File menu).

The Save PES Stream dialog box is displayed with the following
parameters:

� The All Stream ID  and All Packets options are selected.

� The stream ID of the active interpreted view is displayed in the Stream
ID  text box.

� The item number displayed in the active interpreted view is displayed in
the From and To text boxes.
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Use Table 2–4 to determine the choices you need to make from the Save PES
Stream dialog box options.

Table 2–4: Save PES Stream option matrix 

PES Packets group Packet Stream ID group

All Streams ID Select Streams ID

All Packets Extracts all of the PES packets
in the stream.

Extracts all of the packets for the
indicated element from the stream.
Indicate which element to extract by
entering its stream ID in the Stream
ID text box.

Select Number Extracts all of the packets in the
range of PES packets you
indicate in the From and To text
boxes. The range entered in the
text boxes is inclusive.

Extracts n number of x elements from
the stream.

n represents the number of items
found in the range of packets indi-
cated in the From and To text boxes.
The range is inclusive and begins
with the item listed in the From text
box. For example, entering 12 and 18
in the From and To text boxes will
extract seven items of element x,
starting with the 12th such item in the
stream.

x represents the element you want to
extract. You determine which element
to extract by entering the appropriate
stream ID in the Stream ID text box.

2. After you have chosen the options you want from the Pes Packets and
Packet Stream ID groups and have entered the appropriate values in the text
boxes, select OK and a standard Save As dialog box is displayed.

3. Select the drive, directory, and file name of the new file you will create using
the options in the Save as dialog box.

You can make managing your files easier if you use the following suggested
file name extensions:

� Use .psd for program stream directory files.

� Use .psm for program stream map files.

� Use .pes for packetized elementary stream files.

4. Select OK .
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If you entered a number into either the From or To text box that is greater
than the total number of items in the stream for the element you are
extracting, you will see an End of File error message and the resulting file
may be unusable.

Extracting elementary streams. You can extract elementary streams using one of
the following procedures:

1. Double-click a Video, Audio, or Data icon.

2. Use standard Windows techniques to select the drive, directory, and file
name you will create using the options provided in the Save as dialog box.
The default file name extensions for saving elementary streams are indicated
in the following list (these extensions are automatically appended to the file
name displayed in the File Name: text box):

� Video streams use .vid file name extensions.

� Audio streams use .aud file name extensions.

� Data streams use .dat file name extensions.

You can also use the Elementary Stream selection from the View menu to extract
and save elementary streams.

1. Navigate to the Hierarchic or PES packet interpreted view for the elementary
stream you want to extract, and then select Elementary Stream from the
View menu.

2. Enter the stream ID for the elementary stream you want to extract in the
dialog box.

3. Use standard Windows techniques to select the drive, directory, and file
name you will create using the options provided in the Save as dialog box.

The default extension for all elementary streams saved using this procedure
is .es.
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Finally, you can automatically display an elementary stream and analyze it using
the MPEG Audio Stream Analyzer or the MPEG Video Stream Analyzer, if the
Elementary Stream Analyzer is installed on your system:

1. Right-click an Audio or Video icon.

2. Select either Analyze with Video Stream Analyzer or Analyze with Audio
Stream Analyzer from the submenu.

The appropriate application will be opened with the extracted elementary
stream displayed.

You can print the information displayed in the hierarchic, interpreted, hexade-
cimal, and binary view windows. To print a view window, use the following
procedure:

1. Select Print Setup from the File menu, and then use the options provided in
the dialog box to configure the printer and document characteristics for your
document. (This step is optional.)

2. Select Print  from the File menu and use standard Windows techniques to
send the file to the printer.

To quit the MPEG Program Stream Analyzer, select Exit  from the File menu.

Printing Program Stream
Data

Quitting the MPEG
Program Stream Analyzer
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Menu Selections
Table 2–5 is a quick reference to the menu selections of the MPEG Program
Stream Analyzer and briefly describes what happens when you make the menu
selection. Page references indicate the page on which you can find more
information about specific menu selections.

Table 2–5: Menu selections 

Menu Selection Result

File Open Displays the Open dialog box from which you
identify the existing file you want to view. See page
2–11.

Save as Displays the Stream Save dialog box from which
you indicate which portion of the stream you want to
save. See page 2–12.

Print Displays a standard Print dialog box from which you
can print the active view window.

Printer setup Displays the Page Setup dialog box. The dialog box
also provides access to printer options.

Exit Quits the MPEG Program Stream Analyzer.

Edit Next Item Displays the next item in the active view.

Previous Item Displays the previous item in the active view.

First Item Displays the first item in the active view.

Last Item Displays the last item in the active view.

Go to Displays the specified item in the active view.

Number of Items Calculates the number of items in the active view,
and then displays the number in the upper portion of
the active view window.

Next error Displays the next item in the active view with either
a CRC or syntactic error.

View Packs View Displays the Pack header interpreted view for the
active program stream. See page 3–2.

(PES) Packets Displays a dialog box in which you enter the stream
ID of the elementary stream you want to view. See
page 3–3.

Elementary Stream Displays a dialog box in which you enter the stream
ID of the elementary stream you want to extract.
See page 2–16.

PS Map Displays the program stream map interpreted view
for the active program stream. See page 3–4.

PS Directory Displays the program stream directory interpreted
view for the active program stream. See page 3–5.
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Table 2–5: Menu selections (cont.)

Menu ResultSelection

Analysis Characteristics

Multiplex Rate Displays the multiplex rate for the program stream.

Packs/Packets Map Displays the Pack Headers/Packets Map view
showing the distribution of stream_IDs and packets
for the program stream. See page 3–7.

Syntactic/Semantic Initiates a syntactic analysis on the active stream or
element. See page 3–14.

Consistency Initiates an analysis on the consistency of active
stream. See page 3–15.

Temporal

SCR Initiates an analysis of the system clock reference
clocks for the active program stream. See page 3–8.

PTS/DTS Displays a dialog box in which you enter the stream
number of the elementary stream upon which you
want to perform a presentation/decoding time stamp
analysis. See page 3–10.

Automatic Initiates the analyses selected using the Automatic
Analysis selection from the Options menu. See
page 3–17.

Options DVD Inactive. This menu selection will be used in future
enhancements.

Automatic Analyses Displays a dialog box from which you select the
types of analyses you want performed when you
select Automatic from the Analysis window. 
See page 3–19.

Interpretation Displays the Interpreted view option dialog box from
which you can choose to display either the length or
the position of the structures in the interpreted
views. See page 3–22.

Base Displays the Base dialog box from which you set the
numeric base (decimal or hexadecimal) used for
various views.

Messages Output Displays a dialog box from which you can select the
drive and directory into which the output from
analyses are written. For each program or system
stream file analyzed, one .log file is generated. To
prevent this file from being appended to, copy it into
another location or rename it. See page 3–20.

Font Displays the Font dialog box from which you set the
font used for most of the views windows. (The
Binary and Hexadecimal view windows are not
affected by the font selection.)
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Table 2–5: Menu selections (cont.)

Menu ResultSelection

Options Configuration

Save Saves the current analyzer configuration. 
See page 3–22.

Load Loads a saved configuration file into the current
MPEG Program Stream Analyzer session. See page
3–22.

Default Loads the default configuration into the current
MPEG Program Stream Analyzer session. See page
3–22.

Window Cascade Overlaps the open windows on top of one another.

Tile Fits the open view windows to the application
window.

Arrange icons Arranges all minimized window icons to the bottom
of the application window.

Close view Closes the selected view window.

Close all Closes all of the view windows.

Add view Displays a submenu from which you can choose to
add a view window identical to the selected view or
a different view of the displayed information. See
page 3–6.

Open view windows Lists all of the open view windows, including any
minimized windows. Select a view window from the
list to make it the active view window. A checkmark
indicates the active view window.

Help Contents Displays the MPEG Program Stream Analyzer Help
contents from which you can choose or search for a
specific help topic.

Using help Displays the Windows Help contents.

About MPEG Audio Stream
Analyzer

Displays the software version number and copyright
information about the MPEG Program Stream
Analyzer.
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Reference

Reference provides detailed information about the MPEG Program Stream
Analyzer. This chapter is organized into the following sections:

� Interpreted Views describes each of the interpreted views enabled by the
MPEG Program Stream Analyzer.

� Additional Views describes other views used by the analyzer to display and
interpret program stream data.

� Analyzing Program Streams describes the types of analyses available using
the MPEG Program Stream Analyzer.

� Options Menu Reference provides a reference for the Options menu
selections that allow you to configure the MPEG Program Stream Analyzer.

NOTE. For information about common Windows interface elements such as scroll
bars and window controls, see your Windows documentation.

Interpreted Views
Interpreted views provide a graphical user interface for examining MPEG
program stream elements. This section describes individual interpreted views and
is organized alphabetically.

See Interpreted View Windows beginning on page 2–7 for a description of, and
how to use, common interactive characteristics of interpreted view windows such
as, navigating through the items of an interpreted view and descriptions of the
interface elements.

NOTE. The MPEG Program Stream Analyzer analyzes both program and system
streams. The illustrations in this section show the interpreted view windows for
an MPEG2 program stream. The interpreted views of MPEG1 system streams
are similar, but will typically look simpler. Furthermore, system streams do not
have program stream map and program stream directory PES packet elements.
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The Pack header interpreted view displays the values found in pack_header()
and, if present, system_header() elements. Display the Pack header interpreted
view window by double-clicking the PS or Pack icon from within the Hierarchic
view window (both icons display the Pack Header interpreted view). Alterna-
tively, select Packs View from the View menu.

Pack header data is given on the first line of the display, system header informa-
tion is given in the second line, and elementary stream specific information is
given on subsequent lines.

The following list indicates some of the important Pack header fields displayed
by this interpreted view:

� System clock reference

� Program multiplex rate

� Target decoder data

To view the bytes displayed in the interpreted view in hexadecimal format,
double-click the stuffing bytes or Data field rectangles.

Use the command buttons on the Edit toolbar (or the selections from the Edit
menu) to navigate through the pack header items.

Pack Header View
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The PES Packet interpreted view displays the values found in PES_packet()
elements. Display the PES packet interpreted view by double-clicking a PES
icon from within the Hierarchic view. Alternatively, select (PES) Packets from
the View menu, and then enter the stream ID of the audio, video, or data stream
you want to view.

The following list indicates some of the important PES Packet fields displayed
by this interpreted view:

� Stream ID

� Scrambling control

� Copyright information

� PTS/DTS and ESCR time stamps

� Target decoder data

� Previous PES CRC data

� Trick mode controls and flags

� Field ID data

To view the bytes displayed in the interpreted view in hexadecimal format,
double-click the PES packet data byte field rectangle.

Use the command buttons on the Edit toolbar (or the selections from the Edit
menu) to navigate through the PES Packet items.

PES Packet View
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The Program Stream Map (PSM) interpreted view displays the values found in
program_stream_map() elements. Display the Program stream map interpreted
view by double-clicking the PMT icon from within the Hierarchic view window.
Alternatively, select PS Map from the View menu.

The following list indicates some of the important PSM fields displayed by this
interpreted view:

� PSM map ID, length, and version

� Descriptors

� Elementary stream IDs and types

� CRC values

To view the bytes contained in the displayed item select the Add View command
button, and then select Binary  or Hexadecimal from the submenu.

Use the command buttons on the Edit toolbar (or the selections from the Edit
menu) to navigate through the program stream map items. You can check all of
the CRC values in a program stream using the Next error command button from
the Edit toolbar. The analyzer will check the program stream map syntax for the
active stream, including CRC values, and display the next item with an error.

Program Stream Map View
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The Program Stream Directory (PSD) interpreted view displays the values found
in program_stream_directory() elements. Display the PSD interpreted view by
double-clicking the PSD icon from within the Hierarchic view. Alternatively,
select PS Directory from the View menu.

The following list indicates some of the important PSD fields displayed by this
interpreted view:

� PES packet length

� Number of access units

� Previous and next directory offsets

� PES header offset of the referenced access unit

� PTS of the referenced access unit

To view the bytes contained in the displayed item, select the Add View
command button, and then select Binary  or Hexadecimal from the submenu.

Use the command buttons on the Edit toolbar (or the selections from the Edit
menu) to navigate through the program stream directory items.

Program Stream Directory
View
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Additional Views
This section describes additional views used by the MPEG Program Stream
Analyzer to display program and system stream data.

You can add multiple view windows to the application window using one of the
following techniques:

� Select the Add View command button from the Upper toolbar, and then
select the view you want displayed from the submenu.

� Select Add View from the Window menu, and then select the view you want
displayed from the submenu.

Table 3–1 lists the views you can add from within the view windows indicated.

Table 3–1: Add view options 

View window Add view options

Hierarchic view An identical Hierarchic view

Interpreted view An identical interpreted view
A Binary or Hexadecimal view

Binary or Hexadecimal view An interpreted view of the bitstream
A Binary or Hexadecimal view

SCR view An SCR Graphic view
An SCR Values view

PTS/DTS view A PTS/DTS Graphic view
A PTS/DTS Values view

The Add View command button and menu selection are not available from the
Multiplex Rate and Pack Headers/Packets Map view windows.

If you add views using the Add View command button (or menu selection), and
then navigate to another item using the resulting window, the first window (the
parent window) also displays the new item. In order to view multiple, unique
items of program stream elements, add another interpreted view window by
selecting the appropriate icon from the Hierarchic view.

Adding Views
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Binary and Hexadecimal views show the bitstream of the interpreted view from
which it was accessed in either binary or hexadecimal format. Access these
views from interpreted view windows by clicking the Add View icon on the
upper toolbar and selecting Binary  or Hexadecimal from the submenu.

The blue text in the binary and hexadecimal views represents the data that
appears in the header of the interpreted view.

You can also display binary and hexadecimal views of many program stream
elements by double-clicking the three dimensional data packet fields in some of
the interpreted views.

The Multiplex Rate view window displays the multiplex rate for the active
program stream. Display the multiplex rate using one of the following  methods:

� Right-click a PS or Pack icon, and then select Rate from the submenu.

� From the Hierarchic view, select Characteristics from the Analysis menu,
and then select Multiplex Rate from the submenu.

The Multiplex Rate view window is a static display.

The Pack Headers/Packets Map view window displays the distribution of the
program stream items in the packets of the program stream. To display the Pack
Headers/Packets Map view window, use one of the following techniques:

� Right-click the PS or Pack icon, and then select Packets Map from the
submenu.

� From the Hierarchic view, select Characteristics from the Analysis menu,
and then select Packs/Packets Map from the submenu.

Binary and Hexadecimal
Views

Multiplex Rate View

Pack Headers/Packets
Map View
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This view of the program stream shows the distribution of packets and indicates
the type and stream ID of the data encoded in each packet. Each Pack Headers/
Packets map window displays up to 100 packets.

� The color reference at the top of the window maps the colors used in the text
below to the program stream elements that can be displayed using the MPEG
Program Stream Analyzer. Not all of the data types will be found in every
program stream.

� The numbers in parentheses along the left-hand side of the window are the
packet numbers for the first packet shown in that row.

The first colored text in a row represents the packet whose number is
indicated in parentheses immediately to the left.

� The colored text indicates the stream ID of the data encoded in that packet.

SCR clocks are used as timing references at the decoder for the program stream
and are encoded in the pack layer. The MPEG Program Stream Analyzer
analyzes and displays system clock reference data using two SCR Clock views:
an SCR Graphical View and an SCR Values View.

SCR Graphic view. To display the graphical SCR view window, using one of the
following techniques:

� From the Hierarchic view, right click the PS or Pack icon, and then select
SCR from the submenu.

� From the Hierarchic view, select Temporal from the Analysis menu, and
then select SCR from the submenu.

When you display the SCR Clock View, the MPEG Program Stream Analyzer
analyzes the SCR data for the active program stream. If errors are found during
the analysis, they are indicated on the display as red arrows leading from SCR
clock icons to the black line, which represents time. SCR clocks without errors
are indicated using black arrows.

SCR Clock Views
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Each SCR view window displays ten SCR clocks, starting with SCR numbers
one through ten. If successive clock references are very close together (in time),
some of the clock reference icons may not be visible. To access the data for these
clock references you need to display the SCR Values view, which is described in
the next section. Click the Next Item command button to display successive
SCR items or use the Go to Item button to display a specific item.

To display the values associated with each clock, double-click one of the SCR
icons and an SCR number n pop-up window is displayed (n is the number of the
clock reference you double-clicked). See the previous illustration. In this display,
bad SCR values are displayed in red. You can drag this pop-up window to a new
position by clicking and dragging the title bar. Dismiss the window by clicking
anywhere outside of the pop-up in the application window.

SCR Icon

SCR Values pop-up window

Some of the displayed values are encoded in the program stream itself (for
instance, SCR Base and SCR Extension values) and some are derived (for
instance, SCRI – SCRV and FBP – LBPP values). Derived values are based on
the values encoded in the program stream multiplex rate, SCR base, and SCR
extension fields.

SCR Values view. In the graphical view, some of the SCR clocks may not be
visible. This occurs when the time between successive clocks is too small for the
display to resolve. However, the SCR Values view window displays the SCR
values for all ten SCR clocks. To access this display, click the Add View button
while the SCR graphical display is active, and then select SCR Values from the
submenu.
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Use the scroll bar to view the values for the ten displayed clocks. Click the Next
Item command button to display successive clocks, or use the Go to Item
command button to select a specific system clock reference to display. As with
the graphical display, red values indicate errors.

PTS/DTS clocks are used as timing references at the decoder for presentation
and decoding the access units of the PES packets in which they are encoded. The
PTS/DTS Clock views display presentation and decoding time stamps for the
selected elementary stream. Like SCR clocks, you can display PTS/DTS clocks
in both graphical and numerical formats.

PTS/DTS Graphic view. To display the graphical view of PTS/DTS clocks,
right-click a PES packet icon, and then choose PTS/DTS from the submenu.

You can also display the PTS/DTS view window using the following procedure:

1. From the Hierarchic view, select Temporal from the Analysis menu.

2. Select PTS/DTS from the submenu.

NOTE. You cannot perform PTS/DTS analyses on data elementary streams.

PTS/DTS Clock Views
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3. In the PTS/DTS Analysis dialog box, enter the stream number of the audio
or video elementary stream for which you want to display the PTS/DTS
values, and then click OK .

Use the number of the stream as it appears in the hierarchy of the Hierarchic
view. For instance, if the Hierarchic view for the active file looked like the
following illustration, you would enter “2” in the PTS/DTS Analysis text
box to analyze the audio elementary stream. You would enter “1” to analyze
the video elementary stream (do not enter the stream ID).

Elementary Stream  “1”

Elementary Stream  “2”

When you display the PTS/DTS view, the MPEG Program Stream Analyzer
analyzes the PTS/DTS values for the active program stream and displays the first
four PTS/DTS items. If successive time stamp references are very close together
(in time), some of the PTS or DTS icons may not be visible. To access the data
for these references you need to display the PTS/DTS Values view, which is
described in the next section beginning on page 3–13.
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If errors are found during the analysis, they are indicated on the display as red
arrows leading from PTS/DTS icons to the black line, which represents time.
PTS/DTS clocks without errors are indicated using black arrows. Use the Next
Item command button to display successive PTS/DTS items or use the Go to
Item to display a specific item.

Table 3–2 lists the icons used in the PTS/DTS view and indicates the type of
information displayed when you double-click the icon.

Table 3–2: PTS/DTS view icons 

Icon Represents1 Double-click to display

SCR number n The system clock reference value associated with the
displayed access units.

The item number of the pack containing the SCR value.

Arrived number n The time that the access unit (the encoded data for a
picture or block of sound) arrived at the decoder.

The elapsed time since the last bit of the previous PTS/DTS
field arrived at the decoder.

The PES packet number containing the displayed access
unit.

PTS number n The presentation time stamp value.

The PES packet item number containing the PTS value.

DTS number n The decoding time stamp value.

The PES packet item number containing the DTS value.
2 Access Unit number n The time that the first bit of the displayed access unit was

decoded (relative to the first SCR clock).

The time that the last bit of the displayed access unit was
decoded (relative to the first SCR clock).

The number of bytes in the displayed access unit.

The type of picture for the selected access unit: B-, P-, or
I-Picture3.

The sequence in which the decoded pictures are to be
displayed relative to the most recent I-picture3 (Reference
time for I-pictures is zero).

1 n represents the position of the displayed data relative to the first like data item in
the program stream. For example, PTS number 2 means that the displayed PTS value
is the second instance of the presentation time stamp in the program stream.

2 Access Unit icons can represent multiple access units.
3 Picture type and sequence information is displayed only for video elementary

streams.
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The message windows displayed when you double-click icons in the PTS/DTS
view show errors in red. You can drag these windows to a new position by
clicking and dragging the title bar. Dismiss the windows by clicking anywhere
outside of the pop-up in the application window.

PTS/DTS Values view. In the graphical view, some of the presentation/decoding
time stamps and access unit icons may not be visible, or may be difficult to
select. To display all of the values represented in the active PTS/DTS view, click
the Add View button, and then select PTS/DTS Values from the submenu.

In the PTS/DTS Values view, PTS/DTS values are displayed in the two left
columns, and access unit data is displayed in the two right columns. The total
number of access units displayed is listed at the top of each window. Red values
indicate errors.

Access unit columnsPTS/DTS values columns

Use the Next Item command button to display successive PTS/DTS items, or
use the Go to command button to select a specific item.
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Analyzing Program Streams
The MPEG Program Stream Analyzer provides multiple analysis functions for
checking different aspects of MPEG program and system streams. The following
analysis functions are described in this section:

� Syntactic analysis. Syntactic analyses check the conformance of the values
encoded in the bitstream to MPEG standards.

� Consistency analysis. Consistency analyses check the conformance of the
fields and values encoded in the bitstream relative to each other as required
in the MPEG standards for program and system streams.

� SCR  analyses. SCR analyses checks the temporal references for the program
stream.

� PTS/DTS. PTS/DTS analyses checks the temporal references for a specific
elementary stream.

One of the Analysis menu selections is Automatic, which initiates any combina-
tion of the above analyses. See Automatic Analyses on page 3–19 for more
information about setting the options for automatic analyses.

Syntactic analyses check the conformance of the values encoded in the bitstream
to MPEG standards. You can perform syntactic analyses on a specific MPEG
element or on the entire program stream. To perform an analysis on the entire
stream, use the following procedure (to perform a syntactic analysis on a selected
element, use the same procedure, but first make the interpreted view of the
element you want to analyze the active view):

1. Navigate to the Hierarchic view for the program stream you want to analyze.

2. Select Syntactic Semantic from the Analysis menu.

The analyzer initiates a syntactic analysis of the program stream.

After the analysis is complete, the following message window is displayed
listing the syntactic errors found in the file.

Errors are listed by MPEG element, item number, field name, and error.

Syntactic Analysis
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3. To display the interpreted view for item containing an error, double-click an
error message.

The appropriate interpreted view is displayed and the value in error is
displayed in red.

When you perform a syntactic analysis on a program or system stream, or any
element of a stream, the analyzer creates a text file of the resulting errors (see
Messages Output on page 3–20).

Consistency analyses check the conformance of the fields and values encoded in
the bitstream relative to each other as required in the MPEG standards for
program and system streams. Consistency analyses can only be performed from
the Hierarchic view. To perform a semantic analysis, use the following proce-
dure:

1. Navigate to the Hierarchic view for the program stream you want to analyze.

2. Select Consistency from the Analysis menu.

The analyzer initiates a semantic analysis among the elements and fields of
the program stream.

3. After the analysis is complete, a message box similar to the syntactic
analysis message window is displayed listing all consistency errors.

When you perform a consistency analysis on a program or system stream, the
analyzer creates a text file of the resulting errors (see Messages Output on
page 3–20).

Consistency Analysis
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You can perform two types of temporal, or time-based, analyses on program
streams: SCR and PTS/DTS analyses. SCR clocks are used as timing references
at the decoder for the program stream. PTS/DTS clocks are used as references for
the elementary stream in which they are encoded.

SCR analysis. To perform an SCR analysis on a program stream, use the
following procedure:

1. Right-click the PS or Pack icon, and then select SCR from the submenu.
(Alternatively, select Temporal from the File menu, and then select SCR
from the submenu when the Hierarchic view or Pack header interpreted view
is active.)

2. The SCR Clock View is displayed. See SCR Clock views beginning on
page 3–8 for details about how to interpret the resulting display.

PTS/DTS analysis. To perform a PTS/DTS analysis on a program stream, use the
following procedure:

1. Right-click a video or audio PES packet icon, and then select PTS/DTS
from the submenu. (Alternatively, select Temporal from the File menu, and
then select PTS/DTS from the submenu when the Hierarchic view or Pes
Packet interpreted view is active.)

2. If you selected PTS/DTS from the File menu, the PTS/DTS Analysis dialog
box will be displayed. Enter the number of the video or audio elementary
stream you want to analyze in the text box.

Temporal Analysis
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Use the number of the stream as it appears in the hierarchy of the Hierarchic
view. For instance, if the Hierarchic view for the active file looked like the
following illustration, you would enter “2” in the PTS/DTS Analysis text
box to analyze the audio elementary stream. You would enter “1” to analyze
the video elementary stream (do not enter the stream ID).

Elementary Stream  “1”

Elementary Stream  “2”

3. The PTS/DTS Clock View is displayed. See PTS/DTS Clock views
beginning on page 3–10 for details about how to interpret the resulting
display.

The Automatic analysis selection from the Analysis menu allows you to
perform any combination of analyses described in this section without having to
select them individually. When you perform an automatic analysis on a stream,
the analyzer creates a text file of the resulting errors (see Messages Output on
page 3–20).

To perform an automatic analysis on the active program stream, use the
following procedure:

1. Navigate to the Hierarchic view for the program stream on which you want
to perform the analyses.

2. Select Automatic from the Analysis menu.

The resulting Automatic analysis window indicates which analyses are
being performed. (See Automatic Analyses on page 3–19 for information
about how to specify which analyses are performed when you select
Automatic from the Analysis menu.)

Automatic Analysis
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3. To stop the analysis, press the button at the bottom of the message window.

In the following illustration, the SCR and PTS/DTS analyses have been
disabled, the Syntactic analysis is completed, and Consistency analysis is
being performed.

Disabled analyses

Analysis being performed

Completed analysis with errors

If errors are detected, the word Errors is displayed in red in the row for the
appropriate analysis under the Result column.

4. Double-click the word Errors, to display a message windows listing the
errors. Double-click an error message in the Syntactic, SCR, or PTS/DTS
analysis message windows and the item in error is displayed in the
appropriate view window.

You can have the analyzer automatically generate an error log file for the
analyzed file using the Analyses Result Output dialog box (see Messages
Output on page 3–20). This file is appended to each time an analysis is
performed.

NOTE. To generate the error log file, you need to set the Messages Output in file
option in the Messages Output dialog box each time you start an MPEG
Program Stream Analyzer session. See page 3–20.
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Options Menu Reference
The Options menu selections allow you to configure specific MPEG Program
Stream Analyzer parameters. The parameters in use when you exit the applica-
tion are used to configure the analyzer when you open it again. This section
describes the parameters you can set using the Options menu selections.

This menu selection is inactive. DVD analyses will be supported in a future
enhancement to the MPEG Program Stream Analyzer.

The options you set using the Options for automatic analysis dialog box allow
you to perform any combination of the analyses described in Analyzing Program
Streams (beginning on page 3–14) without having to select them individually.

To specify which analyses should be performed when Automatic is selected from
the Analysis menu, use the following procedure:

1. Select Automatic Analyses from the Options menu and the Options for
automatic analysis dialog box is displayed.

2. Select any combination of analyses from the dialog box. Until you change
these settings, the selected analyses will be performed every time you select
Automatic from the Analysis menu.

DVD

Automatic Analyses
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Use the Base menu selection to determine how the interpreted views display the
program stream values: in either decimal or hexadecimal base. The default is
decimal base. Toggle between the two by pressing the F2 function key.

Use the Messages Output menu selection to specify the following parameters:

� Whether an error log file is automatically created when Syntactic/Semantic,
Consistency, or Automatic is selected from the Analysis menu.

NOTE. SCR and PTS/DTS data is logged when automatic analyses are
performed, but not when SCR or PTS/DTS analyses are performed singly.

� If created, the directory in which the error log file is written.

1. To automatically create an error log file, select the Messages output to File
check box.

If you clear the Messages Output in File check box, no error log file will be
generated when analyses are performed.

NOTE. Each time you exit the MPEG Program Stream Analyzer, the Messages
Output in File check box is cleared. You need to select this option each time you
begin an MPEG Program Stream Analyzer session in order to automatically
generate error log files.

Base

Messages Output
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2. Specify the directory into which log files are written by entering a new
directory path in the File Directory text box.

Error log files are named using the file name with a .log file name extension.
Subsequent analyses results are appended to files without destroying previous
data. Each new analysis is indicated with an error message header providing the
following information:

� View from which the analysis was performed (for Syntactic/Semantic
analyses)

� Program or system stream file name (for Syntactic/Semantic analyses)

� Date and time the error messages were generated

For automatic analyses, the following headers are also used in the body of the
error messages:

� The type of analysis performed separates the list of error messages (error
messages of a specific type follow the analysis type separator).

� An End of report for automatic analysis statement indicates where the error
messages for that particular automatic analysis end.

Finally, the error messages in the error log files are formatted similarly to the
error message windows displayed in the analyzer: Errors are listed by MPEG
element, item number, field name, and error.

Use the Font menu selection to specify the font (typeface, style, and size) used
for displaying information in the following analyzer view windows:

� Hierarchic view windows

� Interpreted view windows

� SCR and PTS/DTS Graphic view windows

Font



Reference

3–22 MTS300 Series Program Stream Analyzer

Use the Interpretation menu selection to specify whether to display length or
position information in interpreted views. The Length and Position check boxes
shown in the following illustration are cleared by default.

� Select Length to display the number of bytes in a field.

� Select Position to display the position (in bytes) of the field  relative to the
first bit displayed in the interpreted view.

The following Options menu selections allow you to save and load configuration
files.

Read configuration. Choose Read configuration from the Options menu to restore
a configuration file (a .acf file) that you saved earlier. A standard Windows Open
dialog box appears. Change the Drive and Directory if necessary and then select
the file name. Click OK  to restore the configuration saved in the file.

Save configuration. Use Save configuration to save the current option settings to
a file. A standard Windows Save as dialog box opens. Be sure to select a Drive
and Directory that will make it easy to later retrieve the file; then enter a
descriptive name for the configuration file and click OK . The file receives the
extension *.acf by default. 

Set default configuration. Use this menu selection to revert the current options
settings to the default settings.

Interpretation

Configuration Files
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Index
Symbols
?, symbol, 2–5

A
Access unit, icon, 3–12
Add view

menu selection, 2–20
options, 3–6
upper toolbar command button, 2–3

Address, Tektronix, vi
Analysis

automatic, 3–17
consistency, 3–15
CRC, 3–4
error message output file, 3–20
PTS/DTS, 3–16
SCR, 3–16
syntax, 3–14

Analyzing program streams, procedures for, 3–14
Application window, 2–2
Arrange icons, menu selection, 2–20
Automatic, analyses procedure, 3–17
Automatic analysis, options, 3–19

B
Base, decimal/hexadecimal options, 3–20
Basic Operations, 2–11
Binary view, 2–10, 3–7
Blue text, in binary and hexadecimal views, 3–7
Buttons

Edit toolbar, 2–3
Upper toolbar, 2–3

C
Cascade, menu selection, 2–20
Close all, menu selection, 2–20
Close view, menu selection, 2–20
Color, in pack header/packets map view, 3–8
Common view window elements, 2–4
Configuration, read, save, and set default, 3–22
Consistency, analysis procedure, 3–15
Contacting Tektronix, vi
CRC, in PSM interpreted view, 3–4

D
Decimal/hexadecimal base, switching between bases,

2–9, 3–20

E
Edit toolbar, 2–3
Element, definition, 2–4, 2–10
Elementary streams, extracting and saving, 2–16
End of file, error message, 2–16
Error

log files, 3–18
log files (.log), 3–20
message window, 3–14

Exit, menu selection, 2–17
Extracting

elementary streams, 2–16
packets, 2–14
packs, 2–13
program streams, 2–12

F
FBP (first byte of pack), 3–9
Fields, interpreting position or length, 3–22
First Item, edit toolbar command button, 2–3
First time operation, 1–2
Font, setting, 3–21
Functional overview, 2–2

G
Go to, edit toolbar command button, 2–3
Gray rectangles, 2–8

H
Hexadecimal view, 2–10, 3–7
Hexadecimal/decimal base, switching between, 2–9,

3–20
Hierarchic view, overview, 2–5
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I
Icons

Edit toolbar, 2–3
program stream analyzer, 2–2
PTS/DTS view, 3–12
Upper toolbar, 2–3

Interface description, interpreted view, 2–7
Interpretation, position or length, 3–22
Interpreted views

interface elements, 2–7
pack header, 3–2
PES packet, 3–3
PSD, 3–5
PSM, 3–4
rectangles, 2–8

Item, definition, 2–4, 2–10
Item number, in interpreted view, 2–4, 2–8

L
Large rectangles, in interpreted views, 2–8
Last, edit toolbar command button, 2–3
LBPP (last byte of previous pack), 3–9
Length, interpreting field, 3–22
List of open view windows, 2–20
Log file (.log), generating, 3–20
Lower toolbar, 2–3

M
Marker bit indicators, 2–8
Marker bits, interpreted views, 2–8
Menu bar, 2–3
Menu selections, reference, 2–18
Message output, options, 3–20
Multiplex rate view, 3–7

N
Navigating, interpreted views, 2–10
Next, edit toolbar command button, 2–3
Next error, edit toolbar command button, 2–3
Number of items, edit toolbar command button, 2–3

O
Online help, Contents menu selection, 2–20
Open, upper toolbar command button, 2–3
Opening a program stream file, 2–11

P
Pack header, interpreted view, 3–2
Pack headers/packets map, 3–7
Packets, extracting and saving, 2–14
Packs, extracting and saving, 2–13
PES packet, interpreted view, 3–3
Phone number, Tektronix, vi
Position, 2–8

interpreting field, 3–22
Presentation/decoding time stamp

analysis, 3–16
view, 3–10

Previous Item, edit toolbar command button, 2–3
Print, 2–17
Product support, contact information, vi
Program stream directory (PSD), interpreted view, 3–5
Program stream map (PSM), interpreted view, 3–4
Program streams

analyzing, 3–14
opening, 2–11

PTS/DTS
analysis, 3–16
red text in message windows, 3–10

Q
Question mark, symbol, 2–5
Quitting the application, 2–17

R
Rectangles

interpreted views, 2–8
shaded, 2–8

Red text
in automatic analysis message window, 3–18
in interpreted views, 2–9
interpreted views, 3–14
PTS/DTS message windows, 3–10
SCR message windows, 3–9
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S
Save as, upper toolbar command button, 2–3
Saving

elementary streams, 2–16
packets, 2–14
packs, 2–13

SCR analysis, procedure, 3–16
Service information, vi
Service support, contact information, vi
Shaded rectangles, interpreted views, 2–8
Small rectangles, in interpreted views, 2–9
Software version, v
Software version number, v
Start application, 2–2
Status bar, 2–4
Stream number, 3–11, 3–17
Streams

analyzing, 3–14
opening, 2–11
saving, 2–12

Syntactic, error message window, 3–14
Syntactic analysis, procedure, 3–14
System clock reference (SCR)

analysis, 3–16
view, 3–8

T
Tektronix MPEG Test System, v, 1–2
Temporal analyses, 3–16
Three dimensional rectangles, interpreted views, 2–10
Tile, menu selection, 2–20
Title bar, 2–2
Toolbar, edit, 2–3

U
Upper toolbar, 2–3
URL, Tektronix, vi

V
Version, software, v
Version number, v
Vertical lines, in rectangles, 2–8
View window, common elements, 2–4
Views

adding, 3–6
binary and hexadecimal, 2–10, 3–7
hierarchic, 2–5
interpreted, 2–7
multiplex rate, 3–7
pack header, 3–2
pack headers/packets map, 3–7
PES packet, 3–3
program stream directory, 3–5
program stream map, 3–4
PTS/DTS, 3–10
SCR, 3–8

W
Web site address, Tektronix, vi
Window, application, 2–2
Windows

automatic analyses, 3–18
common elements, 2–4
error message, 3–14
Hierarchic view, 2–5
Interpreted view, 2–7

X
X, symbol, 2–5
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